ATTENZIONE agli aggiornamenti di Ubuntu Server!!!!!!

sezione dedicata ai sistemi operativi Linux

ATTENZIONE agli aggiornamenti di Ubuntu Server!!!!!!

Messaggio da leggereda root » 14/09/2014, 9:15

Attenzione all'ultimo aggiornamento di Apache per Ubuntu Server 10.04, quegli incompetenti (per non dire idi0ti) che hanno fatto il pacchetto di aggiornamento di apache, hanno modificato il file di configurazione delle direttive di PHP, per cui se avete un sito in PHP che e' al di fuori di "/var/www" ma e' ad esempio nella /home di un utente, le pagine in PHP non funzioneranno piu', vi apparira' invece una richiesta di scaricare un file PHTML.
Bello trovarselo su un server di produzione dopo aver fatto l'aggiornamento!

Per risolvere la caxxata occorre modificare il file "/etc/apache2/mods-available/php5.conf" commentando alcune righe come sotto indicato (in rosso):

<IfModule mod_php5.c>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-source
</FilesMatch>
# To re-enable php in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
# <IfModule mod_userdir.c>
# <Directory /home/*/public_html>
# php_admin_value engine Off
# </Directory>
# </IfModule>

</IfModule>

Altrimenti i files PHP funzioneranno solo se sono dentro "/var/www"

Ovviamente nessuno ha avvisato della modifica, me ne sono accorto da solo (impossibile non accorgersene!) e ho perso tutta la sera per capire cosa fosse successo.

Quello che odio di Linux e' l'assoluta leggerezza e menefreghsimo di quelli che compilano i pacchetti degli aggiornamenti, con Linux aggiornare il sistema e' sempre una roulette russa!
Se quelli di Ubuntu, invece di rilasciare una nuova release "colabrodo" ogni sei mesi, smettessero di correre e facessero un po' piu' di attenzione, queste cose non succederebbero!
Se vuoi un sistema operativo che non ha la piu' pallida idea di cosa sia la compatibilita' verso il basso, che ti da il "brivido" dell'aggiornamento kamikaze e che soprattutto cambia configurazioni e percorsi alla caxxo, allora scegli Linux!
Maurizio
Avatar utente
root
Amministratore
 
Messaggi: 394
Iscritto il: 10/04/2012, 10:55
Località: Turin

*** UPDATE! ***

Messaggio da leggereda root » 14/09/2014, 9:17

Attenzione all'ultimo aggiornamento di apache 2.2.14 di ubuntu server

Nuovamente l'ultimo aggioramento di Apache 2.2.14 su Ubuntu server mi ha causato un disastro, le pagine web con Joomla con PHP non funzionano piu'.
I file sdi configurazione di apache sono stati modificati tutti e non riesco piu' ad abilitare il modulo PHP5 di Apache.
Sono tre ore che cerco di capire come risolvere il problema.

State attenti a non aggiornare altrimenti se avete un Web Server vi troverete nei guai come me.

Adesso basta, Ubuntu ha veramente esagerato in incompetenza, non usero' mai piu' Ubuntu, usero' Debian puro!
Maurizio
Avatar utente
root
Amministratore
 
Messaggi: 394
Iscritto il: 10/04/2012, 10:55
Località: Turin


Torna a Linux

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron